CRM 2016 On-Premise Install Error–InstallWindowsSearchAction failed

I’ve just done recently an install on-premise where I’ve encountered a number of issues. One of them is the following error message:

Action.Microsoft.Crm.Setup.Common.InstallWindowsSearchAction failed.

The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)

image

The message is pretty explicit, in that a service is not started. Turns out, after a little investigation, that for some reason the SQL Server Service as well as the SQL Server Agent Service are off. This could be the result of a failed SQL update I just got previously, or some other issue. Simply setting these services to Automatic and starting them allows the installation to proceed further with no issue.

image

No, you do not have to restart the installation, just make sure the services are running properly.

Smooth sailing afterward.

Enjoy!

One thought on “CRM 2016 On-Premise Install Error–InstallWindowsSearchAction failed

Add yours

  1. In my case the Windows Search service was disabled. After I enabled and started the CRM installation could be continuing when clicked on the retry button.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

A WordPress.com Website.

Up ↑

%d bloggers like this: